1

I've looked at similar issues on this forum but can't find answer I need.

Basically Problem is article title/ thumbnail photo does not show on Facebook when sharing. This is a massive problem for my website as most traffic comes this way.

Articles are K2 items.

I know next to nothing about code! Facebook debugger tells me this...

http://www.hillingdonishere.co.uk/index.php/articles/item/283-west-drayton-women-s-christmas-campaign-to-help-homeless-snowballs-as-nearly-3-000-aid-project' of type 'website' is invalid because a required property 'og:title' of type 'string' was not provided.

Warning
Curl Error : WRITE_ERROR Error while processing content unencoding: invalid block type

Warning
Errors That Must Be Fixed

Object Missing a Required ValueObject at URL 'http://www.hillingdonishere.co.uk/index.php/articles/item/283-west-drayton-women-s-christmas-campaign-to-help-homeless-snowballs-as-nearly-3-000-aid-project' of type 'website' is invalid because a required property 'og:title' of type 'string' was not provided.

When shared, this is what will be included

Warning
fb:app_id hasn't been included in the meta tags. Specify the app ID so that stories shared to Facebook will be properly attributed to the app. Alternatively, app_id can be set in url when open the share dialog. Otherwise, the default app id( 966242223397117 ) will be assigned.

Based on included and inferred properties, the below preview is what users will see when they share this URL.

1

You need add Opengraph informations in joomla to work with Facebook.

See this reference page to know more about OpenGraph:

http://ogp.me

This plugins to Joomla works fine:

http://e-max.it/joomla-plugins/easy-open-graph

http://extensions.joomla.org/extension/phoca-open-graph

****** UPDATE: I have another plugin working in this site: http://www.sindha.org.br/index.php/blog/gastronomia/4254-a-essencia-dos-temperos

You can see this plugin in: http://extensions.joomla.org/extensions/social-web/social-bookmarking/14094

This puglin create a share button and control Open Graph tags fine.

I hope this helps.

  • Hi Max, thank you very much indeed for your answer. That was very kind of you to take the time and it's much appreciated. I tried phoca already but did not work for me. It also caused problem with other modules. I haven't tried e-max. Do you have a website URL that uses this plugin that I'd be able to look at please? Do you have free version or the 'pay with a tweet' (which by the way I don't understand what they mean) Also, have you used JFB Connect by SourceCoast? It's paid for module&does various other things but mentions specifically the open graph solution. Many thanks, James – Jnhill Jan 10 '16 at 14:07
  • I update my answare. – Max Jan 10 '16 at 15:08
  • thank you again very much Max. I really appreciate your help. Ihave tried ITP social plugin as you suggested. It does help but there are some strange errors with it still. It now shows a photo, whereas before there was no photo. However, the image is now the wrong one! Sometimes the title is wrong as well. I have tried 3 other plug ins and all do the same thing. Same errors I mean. Is there any solution to this that you can suggest please? Again, you're very kind to help. Thank you in advance. James – Jnhill Jan 16 '16 at 17:49
  • 1
    Did you try clear facebook cache from this page you are do tests in: developers.facebook.com/tools/debug – Max Jan 17 '16 at 13:24
  • Hi Max. Yes I did try this. Someone else suggested there are 2 og image files due to k2 component. Said take that of k2 buy dint know how. Any thoughts? ▶ Show quoted text – Jnhill Jan 18 '16 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.