1

Not the place I though I would get stuck. My web host (buddy) reinstalled his OS and since I had never really worked on the site much I opted to start over. He is using NGINX if it matters.

Simple problem to describe really. I cannot click next on the first page of the installation. When you click the button, regardless if the form is filled to completion, a progress bar appears briefly and then goes away.

The version is 3.4.8 but I don't think the version matters. Server is running php v5.4.16 which meets the recommended specs for that.

I have cleared and unzipped the webroot directory a couple of times. This does not seems like a permissions issue but I am not sure.

  • Most of the web searching leads me to template and plugin installations. – Matt Dec 28 '15 at 19:55
5

If you cannot install Joomla, then your server is not filling the minimum requirements. For instance, a basic PHP configuration must have certain PHP extensions enabled.

Check your browser console or server log to review if there is a more detailed error output.

PD: PHP 5.4 is not longer stable, it has reached its end of life. I would recommend at least PHP 5.5 https://secure.php.net/releases/

  • I was planning on updating anyway. I put in PHP 5.5 and there was nothing else to configure. So it was clear that it was just a php issue. Thanks. I just didn't want to change too much in case I wasn't sure what fixed the issue. – Matt Dec 30 '15 at 19:00
2

I used CentOS 7 with NGINX and Joomla 3.6.2 and had the same problem.

Problem: Permission in the folder "/var/lib/php/session" for group "apache"

[user@localhost ~]$ sudo ls -al /var/lib/php/session
total 8
drwxrwx--- 2 root apache 4096 May 12 10:49 .
drwxr-xr-x 3 root root   4096 Aug  9 07:35 ..

Solution: Change the folder permission for group "nginx"

[user@localhost ~]$ sudo chown root:nginx /var/lib/php/session
[user@localhost ~]$ sudo ls -al /var/lib/php/session
total 12
drwxrwx--- 2 root  nginx 4096 Aug  9 08:13 .
drwxr-xr-x 3 root  root  4096 Aug  9 07:35 ..
-rw------- 1 nginx nginx 1261 Aug  9 08:20 sess_a4j5nrejik5lqjq07es7if3dq6

It worked!

2

Another reason for the Installer "Next" button not working is problems with sessions/cookies causing CSRF token checking to fail and redirect back to the first page and the error message to be lost due to lack of a session. Some potential causes:

  • Cookies are disabled in your browser.
  • Cookies are filtered/blocked by a browser extension.
  • Cookies are filtered/blocked by a (forward or reverse) proxy or other middleware.
  • PHP sessions are non-functional due to misconfiguration in php.ini.
  • Using an HTTP connection when session cookies are blocked for non-HTTPS connections (e.g. session.cookie-secure in php.ini).
  • Setting session.cookie_secure = False in php.ini resolved the problem! Thanks! – Tim Eckel May 15 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.