1

When editing an article, and after clicking save I lost all the formatting, hyperlink etc...

I tried to change the text filters to NO FILTERS for the superuser and all other also, but the problem was not solved.

Moreover, I received the error about my DATABASE not being aligned with the CMS (3.4.0-2015-02-26) version. Maybe the two things are related??

If someone can help I would be grateful.

  • How editor you are using? Its appear yor editor dont recognize html tags – Max Dec 20 '15 at 0:48
0

In TinyMCE, some characters or HTML entities are removed for security reasons.

You can try JCE and enable options to accept HTML entities, PHP, CSS, Javascript, etc...

You can select these options as and when you need them.

https://www.joomlacontenteditor.net/downloads/editor/joomla-3

  • Ok great. Im happy you solved. Can you accept my answare please? Thanks. Max. – Max Dec 20 '15 at 16:21
0

Yes i received the error in Extensions > Manage and click Database. I solved it by clicking FIX; moreover i set for all access level the text filter to NO FILTER.

Still not working.

Using JCE solves the problem.

  • I should have added to reset expired cache, and log out. I have updated my answer. I'd say that even if you went back to TinyMCE it will now work. However I too prefer to use JCE and it is a default install for me. – garth Dec 22 '15 at 1:47
0

If you are getting an error notice from your database, it is highly likely that you need to fix that before it will save edits. Select the menu Extensions > Manage and click Database and see if you need to synchronise or fix it.

I have experienced this issue myself, and if your database is up to date, then it is the issue of TinyMCE stripping formatting characters, though changing the filters for the superuser should work.

But you do need to ensure that you clear your cache including resetting the expired cache, and logout. Reset your browser cache, and exit the browser and then reload. It should now work.

My preferred is JCE. I've found that I never have this issue with JCE, and it has better control over the formatting of special characters.

A bit OT but a simpler way to add code is to use Sourcerer from NoNumbers which enables direct inclusion of code between {source}...{/source} tags. Use this with JCE and you have covered every option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.