2

I run Joomla 2.5.28 under Ubuntu 14.04.

I used to have a J 1.5 site, but I upgraded it to 2.5 (the process went well). Now, when I want to add a new menu item into Main menu, strange thing happens. I get a wrong path (when I hover my mouse pointer on that newly created menu item) and I see a home page and domain.com address in the browser's address box (if I click on the menu item nevertheless). Normally when I hover my mouse on any menu item, it's like this:

mydomain.com/index.php/mypage

And what I get is this:

mydomain.com/index.php/Feeds/mypage

That weird "Feeds" thing... That's what I see in the browser's lower left corner (in Mozilla 42.0) where you see the menu item's link. And even when I try to manually enter "mydomain.com/index.php/Feeds/mypage" in the browser, I get a homepage.

Any ideas?

2

This seems indeed very strange.

One thing - I do not know if you already did it - is the "global checkin" (System->Global Checkin)

or

"Repair database" (you can find that [at least in Joomla 3.x] under Extensions->Manage), there is the tab "database" on the left. Maybe fixing (upper left corner) will fix your problem.

This could still cause your problem, even though the installation was successful.

  • No, unfortunately, it hasn't fixed my problem with Joomla... – Gregory Dec 17 '15 at 13:06
  • just to clarify this: does this only appear on your main page, or is it also visible on other subpages? – dennlinger Dec 17 '15 at 13:56
-1

Had to go to Menu Manager in Joomla admin panel and press "Rebuild" button. Probably Virtuemart did something to Joomla db...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.