0

I was under the assumption, that a templates translation file takes precedence over the language strings provided by a module. However currently I have activated a German translation for my template and the German translation strings for some keys are not taking effect, instead the English translation file of the module is being used.

I am wondering what is the best way to solve this:

  1. Provide an additional German translation file for the respective module?
  2. Use an override?
  3. Is there some way I can make Joomla to use the translation string from the template to translate a module?
1

If the extension, for example the module that you mention includes a language file,
the best option is to make an override.

Go to Extensions > Languajes > Overrides
In the screenshot you san see the Filter section for each Languaje

enter image description here

One of the reasons why they could not apply the changes, or why you cant find
the text you want to change, it is because the text is directly embedded in the
code of the module.

Best Regards!

  • My problem is what should I do if I do not know which Keys exist and which not. Or if there are some keys which are already translated and others not. How can I find all the keys which still need to have translations added? I noticed that when I click on new, there is a search function, but it definitely is not able to find all keys. For example I have a key named: 'MOD_IMAGE_SWOOP_READMORE' but if I enter the text of that key in the search this key is not found. – lanoxx Dec 14 '15 at 22:27
  • Another solution could be copy the file en-GB.mod_image_swoop.ini from yoursite/languajes/en-GB to yoursite/languajes/de-DE and change the text for MOD_IMAGE_SWOOP_READMORE – AlejandroVega Dec 15 '15 at 7:00
  • Yes, that works and setting an override for the sting directly in Joomla also works, but I am trying to understand why I cannot find that string using the search function. – lanoxx Dec 15 '15 at 10:01
  • 1
    I made a quick test, I found the extension and I installed it on a test site, then I change the text in site/languajes/en-GB/en-GB.mod_image_swoop.ini from MOD_IMAGE_SWOOP_READMORE="Read more" to MOD_IMAGE_SWOOP_READMORE="Read moreeee", Now I go to Languajes: Override > New and I have searched for the term Read moreeee, here is the screenshot: link – AlejandroVega Dec 15 '15 at 10:48
  • Ok, I see now. It seems the search is dependent on the currently active language filter, maybe that was why I could not find it yesterday. – lanoxx Dec 15 '15 at 10:58
0

Languages: Overrides are the right place to define new labels for each language. You can create them from "Languages Manager" or in language/overrides folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.