0

I've been using Xampp for Mac and the latest version of Joomla. I uploaded the site/database to a live server a couple weeks ago for a developer to look at a problem I was having specifically with his extension. No problems with the upload.

Now that I'm ready to test the site fully, I deleted the previous database and files, uploaded the new files and am now getting an error when importing the database that wasn't there before. I'm scratching my head to what could have happened between now and then as well as what this error is?

MySQL error

Anyone have any ideas? I posted this to the Joomla forums, one person mentioned to try Akeeba Backup rather than doing things manually, but it's having it's own issues uploading to a specific directory on the live server rather than the root. So I will trouble shoot that in the meantime, but honestly I don't see how that will take care of the problem of importing the database.

For testing, I did create a new localhost database and imported the database just fine. It's the live server that's producing the error when uploading.

The localhost version of phpMyAdmin is 4.2.11
The live version of phpMyAdmin is 4.5.0.2

I tried installing a newer version of Xampp, but it's having database issues for the mac version unfortunately.

Please let me know if you need more information or have more questions.

  • Can you try opening your SQL file in a text editor and replacing all '' (2 single quotes together) with \' – Lodder Dec 3 '15 at 20:44
  • Yup, i opened it in bbedit, found 9187 instances of the '' replaced them as directed with \', imported the result and it gave me this: #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\', name varchar(100) NOT NULL, type varchar(100) NOT NULL DEFAULT 'comm' at line 3 Much smaller error message, but very few tables were imported. Only 26 occurrences were found with a space between the 2 single quotes, but it generated the same message as before unfortunately. – mark Dec 3 '15 at 21:09
  • well, i was finally able to use akeebabackup and kickstarter to get the site over. I wish I knew why the database export/import didn't work, but at this point, I'm happy the site is up and being tested. Thx for the try! – mark Dec 4 '15 at 0:19
1

Transferring sites between platforms can be tricky. As you discovered, Akeeba Backup (or similar backup extensions) simplify this error-prone task.

0

I have two methods which worked perfectly for me.

1. Export the Database structure, then the data, then import the structure to the live site, then the data.

2. Use the Command line.

All will be fine.

  • awesome, will definitely try the structure then the data and see if that makes a difference. any how to's or tutorials you can point me to for going the command line route? i'm pretty much a novice to working with db and command line stuff... Thanks so much for the reply, I really appreciate it! – mark Jan 6 '16 at 18:23
  • shared some here patric.xyz/blog I hope it'll help – Patrick Mutwiri Jan 7 '16 at 6:29
  • am not a pro too. Necessity. – Patrick Mutwiri Jan 7 '16 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.