3

I am getting a weird issue on site I 'm setting up on Joomla 3.4.5. When in article manager trying to go the next page (so to show the next bunch of 20 articles), it shows no articles and a message "No matching results".

I am only able to see the articles in the first page (Limit 0,20)

If I set the limit to a higher number, it shows all the articles requested.

So now I m trying to figure out what's going on here... is it a bug, or is it something on my setup?
So to start has anyone experienced this same issue?

Updated info

I have cleared caches and cookies but this is not the case. Other users from their browsers are having it too.

Actually the SQL query (debug on) when running directly in the db is returning the next bunch of items e.g. **(LIMIT 20,20)**, but in the com_content articles default.php template file the $this->items for that query is empty.

I have also disabled 3rd party plugins that could possible interfere (e.g. Falang plugins)... but still I have not come to a conclusion.

  • I'd suggest quickly creating a new installation on Joomla (new, not a backup) and testing again. Let me know the results – Lodder Nov 30 '15 at 21:22
  • @Lodder, I checked on a another 3.4.5 installation but I can't reproduce it. I am thinking to create a new installation including all the extensions and start moving over db tables - and see if the same will happen. – FFrewin Dec 1 '15 at 4:45
2

I just sorted it out... and found what was causing this.

The issue was caused by a bug in the ACL Manager extension. I had ACL Manager 2.4.4 installed and that had a bug as reported here, although the post mentions the bug was for Joomla 2.5, it seems it is also for Joomla 3.x.

Disabling ACL Manager System Plugin, resolves the Articles Manager issue.

Update:

...or updating to latest ACL Manager (currently 2.4.7)

  • Ah I see you have resolved this. So your ACL was messing up - ok cool, so not a core Joomla issue then :) – Phil Taylor Dec 1 '15 at 12:30
  • @PhilTaylor, not a core issue definitely - caused by a 3rd party extension. – FFrewin Dec 1 '15 at 12:31
1

logout, Clear your cookies, to clear your session, and then login again - it seems you might have some other session filter saved somewhere in your session which is causing an invalid SQL query.

  • Hi Phil, thanks for the suggestion. I wish it was that simple... but it's not. It's not only me that is getting the same. Other users from their browsers are having it too. Actually the SQL query (debug on) when running directly in the db is returning the next bunch of items e.g. (LIMIT 20,20), but in the com_content articles template file the $this->items for that query is empty. – FFrewin Dec 1 '15 at 4:29
  • Have you raised this as an official issue in the Joomla issue tracker? issues.joomla.org – Phil Taylor Dec 1 '15 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.