I did an akeeba backup of a live Joomla 2.5.28 site where this issue doesn't exist. Used kickstart to install the backup on my localhost (xampp) and when I go to the administrator login page and enter my credentials, I'm being redirected to the frontend. Manually returning to administrator folder returns the login page. I am able to login on the frontend.

Things I've tried;

  • Password reset via phpmyadmin (as I stated I can login on frontend)
  • Disabled plugins that might be url redirect related. I'm not using JSecure. Plugins that I've disabled include sef, admintools, sh404sef, and a few others which may be suspect.
  • Removed the .htaccess files
  • Set the live site url in configuration.php
  • overrite all system files with a fresh J v2.5.28
  • traceroute on frontend index returns null

I've spent hours and hours searching and have found no working solution. Any help or ideas will be greatly appreciated!

  • 1
    Check to see if you've used Akeeba's admin tools to restrict the IP address that can login.
    – Lance
    Commented Nov 25, 2015 at 3:55
  • 1
    Have you tried restoring a backup without using Akeeba and doing it manually? Might be worth giving this a try too.
    – Lodder
    Commented Nov 26, 2015 at 11:48
  • 3
    try removing live site, that's not needed - public $live_site = '';
    – Marko D
    Commented Nov 27, 2015 at 16:05

2 Answers 2


The things you have tried are correct and a good troubleshooting steps list for the issue you have, with 1 exception:

You mention in your question:

Set the live site url in configuration.php

Actually this should be left empty - almost always (either online or localhost).

Another thing you have to make sure in the configuration file: You should not have assigned any values to the $cookie_ variables, otherwise it's likely you will not be able to login.


This is usually caused by admin tools url restriction or by ip.

If you go into the database and disable akeeba plugins you will be able to login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.