1

I have just transfered a web site to a new host using Akeeba. On the face of things it looks ok but when I try to change something in the global configuration, I get a blank page when saving.

I edite the configuration.php to enable more logging and get the following:

Notice: Undefined index: SERVER_ADDR in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 176 Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: node name or service name not known in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 183 Warning: fsockopen(): unable to connect to :80 (php_network_getaddresses: getaddrinfo failed: node name or service name not known) in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 183 Fatal error: Call to undefined function php_network_getaddresses: getaddrinfo failed: node name or service name not known() in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 188

2

In the Joomla backend, go to your Plugin Manager, and disable the Siteground Cache plugin.

Once done, try making and saving your changes in the Global Configuration.

As much as I love Siteground hosting, I'm not a big fan of their caching facilities.

  • When I try to disable the plugin I get a similar error message. Notice: Undefined index: SERVER_ADDR in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 176 Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: node name or service name not known in /mnt/webw/b2/78/56896778/htdocs/plugins/system/jSGCache/jSGCache.php on line 183 Warning: fsockopen(): unable to connect to :80 (php_network_getaddresses: getaddrinfo failed: node name or service name not known) in /mnt/webw/b2/78/56896778..... – paul Nov 20 '15 at 8:07
  • 1
    Try disabling it via PhpMyAdmin in the #__extensions table – Lodder Nov 20 '15 at 9:44
  • @paul - Glad it worked. If this answered your question, please mark the answer as accepted so others know it has been solved – Lodder Nov 20 '15 at 16:44
1

I had a similar problem but could not disable any extensions that I thought were causing the problem. I had to go into MySQL to disable it.

MariaDB [fe_joomla]> select extension_id, package_id, name, enabled, state from josld_extensions;
+--------------+------------+---------------------------------+---------+-------+
| extension_id | package_id | name                            | enabled | state |
+--------------+------------+---------------------------------+---------+-------+
|        11002 |          0 | System - jSGCache               |       1 |     0 |

MariaDB [fe_joomla]> update josld_extensions set enabled = 0 where extension_id = 11002;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.