I need to add iframes to articles, just as described in this question: iframe gets deleted in joomla jce editor

I tried all of what's mentioned in the replies to that questin (except plugin - I just want to copy/paste an iframe) - no luck, iframes still removed. Joomla 3.4.5, JCE 2.5.11

(I'd have written this in a comment to the linked question, but not allowed)

  • Have you seen the answer provided here? I asked something silimar yesterday joomla.stackexchange.com/questions/14330/…
    – jonboy
    Commented Nov 17, 2015 at 8:31
  • Do you have the iframe plugin? Do you have it set to "YES": joomlacontenteditor.net/support/faq/item/…
    – iamrobert
    Commented Nov 17, 2015 at 14:11
  • @jhonny_s Thanks. That is a very different issue. In your case, as I understood, nothing gets deleted, just changed.
    – Ralf
    Commented Nov 18, 2015 at 6:59
  • @iamrobert Yes, I've seen that article and set it up that way, but made no difference.
    – Ralf
    Commented Nov 18, 2015 at 7:00
  • Meanwhile it is solved, but unfortunately, I don't exactly know why it didn't work and why it works now. One detail was: I did not know that not only iframe needs to be permitted but also iframe attributes. In JCE, don't put it into extended parameters at all. Then, I overlooked a setting in JEvents. JCE forum: joomlacontenteditor.net/support/forum/…
    – Ralf
    Commented Nov 18, 2015 at 7:10

2 Answers 2


One way to find out if the iframe gets deleted by the editor is to disable JCE, and select no editor, then try to save your article with the iframe code pasted in the article body.

To select no editor, go to:

Global Configuration -> Site -> Editor = set to none

Start a new article (so you don't have to care if you mess with any existing published articles), and paste your iframe code and save. If it still gets removed, then it's not a setting with JCE and you should look elsewhere (like content blacklists/whitelists filters).

If however the iframe wasn't removed this time, then it's something with the settings in JCE and you should review them again, following the instructions in the post you found.


I don't know what is wrong with your Joomla! to prevent the normal solutions from working, but you can just circumvent the issue by installing Sourcerer. It usually works and makes adding html to articles in wysiwg mode simple. The link is to the part of tutorial where this is explained so you can directly see if it is simple enough for you. The free version should be good enough for this.

  • I do use Sourcerer, but just to get an iframe in, it seems like overkill. I wish there was a simple and reliable way within Joomla to define which things are permitted in articles and other content.
    – Ralf
    Commented Nov 18, 2015 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.