I developed a new Joomla site in a subfolder on the server and, after finishing development, I have put the site live by moving all the files out of the subfolder in to the top level directory. This is the way I regularly work and have done this so many times!

However, this time I have found that I am not able to make any changes to the global configuration, modules and menus as the Save buttons simply don't work. No error messages, they just don't allow me to click on them. I have also found that the Search Tools filter dropdown in the Article Manager doesn't work either.

It's all very strange and frustrating because, as I say, I have done this before many times with no problems at all.

The only thing I can find out is that it may be something to do with file ownership or permissions but I really don't understand how to fix it.

Does anyone have any idea why this problem has just occurred and how I can fix up the admin to work fully?

Site: http://www.jobutcher.co.uk/ Joomla version: 3.4.5

Many thanks

  • It probably is the file permissions and ownership settings. How are you accessing your site to move files?
    – TryHarder
    Oct 29, 2015 at 10:39

5 Answers 5


Clearing the cache on your web browser usually fixes this issue.

Clearing the Joomla cache at the same time is probably worthwhile too.


Check the file: configuration.php at root level.

This file has some paths to tmp and log subdirectories. You have to manually update the path to the new location.


If clearing browser and Joomla cache won't solve your issue - a first thing to do is to check if Debug and Error Reporting are On and set it to off.

I have seen javascript issues with the toolbar buttons many times, when debugging is On.

If this is not the case for you: Then enable again error reporting to max and see if any errors are appearing.

Open Browser Console and check for Javascript Errors, while you are trying to operate and click these buttons. Also check for broken links to css/js files (it's possible they still link to the old location).

Keep in mind that it's possible there are cached files on server level (e.g. goDaddy use apc cache and such changes take time to reflect, as your php files may still link to the old (subfolder) location.

At the end, make sure that you have moved all files.


I had this problem on the Isis template. The fix I found was to open the index.php in the Isis admin template and on lines 27 and 28 you'll find the following:

// Add JavaScript Frameworks

on line 29, add the following

JHtml::_('behavior.framework', true);

So it should now look like:

// Add JavaScript Frameworks
JHtml::_('behavior.framework', true);

The buttons then started working for me.


I have the same issue, moved Joomla 3 from subfolder to the root but the tabs in administrator don't work. Did not find any solution, tried all mentioned above. The only solution for me - change the debug in configuration and set the css for the debug on website to not be visible... Nothing else worked for me and I dont dare to upgrade now :D

  • Hi Jana, welcome to JSE and thank you for contributing. Please take our tour. I'm not convinced that simply hiding debugging/error output is "a fix". If you are interested in trying to isolate your problem and resolving it is a more effective way, you are welcome to ask a new question if you like. Jan 26, 2022 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.