1

Whenever I embed a tweet with an emoji into a k2 field and save, everything after the first emoji is deleted.

Is there some way I can make TinyMCE recognize emoji?

Here's a picture of before/after saving:

http://imgur.com/a/B7SHK

1

Emoji's a 4 byte characters. This means that your database needs utf8mb4 support to deal with this. Joomla currently does not support this and this is the result (this was part of the cause of the security vulnerability in 3.4.6 and also a similar wordpress security issue from about 12 months ago). The fix has been included in the 3.5 branch for nearly 6 months now and should be shipped with that release in January. This will also require K2 to make some small changes to their database fields in order to add support (collating utf8mb4 rather than utf8 in their database). Until this happens you are best to use images or SVG's rather than unicode characters to add emoji support

0

In TinyMCE, some characters or HTML entities are removed for security reasons.

You can try JCE and enable options to accept HTML entities, PHP, CSS, Javascript, etc...

You can select these options as and when you need them.

https://www.joomlacontenteditor.net/downloads/editor/joomla-3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.