0

I am trying to accomplish clean URLs.

I have turned on URL Rewriting in the Global Configuration.

I have renamed htaccess.txt to .htaccess and left it as it is, except for RewriteBase which I changed to RewriteBase /srv/http/joomla as that is where my Joomla installation resides.

mod_rewrite is enabled in Apache.

There are no .htaccess files above the Joomla installation in the file hierarchy.

When I use a category list and follow its link that URL is nice and clean, but results in a 404 error. The old URLs that include .../index.php/article-name still work. What's wrong?

Full .htaccess:

##
# @package    Joomla
# @copyright  Copyright (C) 2005 - 2015 Open Source Matters. All rights reserved.
# @license    GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that disallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## No directory listings
IndexIgnore *

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

 RewriteBase /srv/http/joomla

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical    folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
  • Are you enabling also "Search Engine Friendly URLs" in global configuration? – Piero Marsilio Oct 15 '15 at 12:54
  • Are you running on Apache?, if you are running on Nginx or IIS .htaccess won´t work – Piero Marsilio Oct 15 '15 at 12:56
  • Have you tried just commenting RewriteBase , normally it is not necesary to change it – Piero Marsilio Oct 15 '15 at 13:01
  • Oh wow, commenting it out actually solved the problem. I feel a little dumb right now. Thanks, man! – kunterbunt Oct 15 '15 at 15:27
  • glad you solve it – Piero Marsilio Oct 15 '15 at 16:46
0

RewriteBase must be with slash at end, something like this: RewriteBase /srv/http/joomla/

To use seo urls in Joomla both settings "Search Engine Friendly URLs" and "Use URL Rewriting" must be activated, see screen.

joomla seo urls settings

-1

Trivially all I had to change was comment out RewriteBase ....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.