0

I recently moved my joomla-based website from my computer (WAMP SERVER) to a shared hosting server on the internet. But i keep getting an error below my site's header that goes thus:

"Strict Standards: Only variables should be passed by reference in /home_directory/hostname/publicfolder/plugins/system/yt/includes/libs/yt-minify.php on line 179"

What do i do? I have set the permissions for both yt-minify.php and the config.php for the YT Framework to 777.

Kindly help. #Joomla

1

Strict standard errors is something a lot of people have asked about. I hope you did some research first.

Basically, your live server is most likely running PHP 5.4+, where by default, strict error are set to appear. They're not an issue so you can simply turn them off.

Firstly, go into your Joomla Global Configuration, and ensure you've seet Error Reporting to default, then check to see if the error still occurs.

If it does, you'll need to disable them by either:

  • Opening the server php.ini and setting error_reporting to E_ALL & ~E_NOTICE & ~E_STRICT

or

  • Adding php_value error_reporting 30711 to your .htaccess file

or

  • Adding ini_set('display_errors', '0'); error_reporting(E_ALL | E_STRICT); to your template's index.php, however this is not recommended
1
  • Thanks! I contacted my hosting server and they switched my PHP account. I had 5.4. native PHP version before that. so it was switched to custom 5.4. version, it has different php settings that native 5.4.
    – proton
    Oct 7 '15 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.