3

My Joomla 3.4.4 website is not showing Database Queries in Joomla Debug Console at the site front-end but it can be seen at the Administrator back-end.

Below is the screenshot at the front-end enter image description here

And here's at the back-end enter image description here

I believe it's not due to my custom template since I have already tried changing the template back to the default protostar template but it's still not working.

Any help would be very appreciated.

  • 2
    does it maybe run out of memory? Can you check logs and try ini_set('memory_limit',;512M'); – jdog Oct 1 '15 at 1:41
  • found no issue with logs and memory_limit @jdog – kolunar Oct 1 '15 at 3:05
  • @jdog found the issue, please see my answer below :) – kolunar Apr 28 '16 at 5:30
3

Found out that the joomla database driver is being overridden by another one which belongs to Falang component that allows you to manage all the content translations. Falang database driver has no debugging implementation and thus only disabling the Falang while debugging the site would solve the issue.

3

This is kinda of necroposting, but an issue still has no fix from Falang author, so here is it. In the file ./plugins/system/falangdriver/falangdriver.php

Find (309 row for Falang 2.6.0):

$db->debug($debug); 

Change to:

$db->setDebug($debug);

Now Joomla debug information will contain all queries. The fix has been submitted to Falang author as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.