1

I was trying to setup a multilingual joomla site, and Faroese wasn't an option so I asked this question: "Add Custom language to content language" but this didn't give the user the opportunity to select faroese in the language switcher, so I tried everything to get it to work, and ended with trying something stupid.

I downloaded the danish language package and changed everything that had da-DK to fo-FO file names and inside files. and made it into a new zip. It successfully installed the package. But when I choose Faroese to my site and administrator site it all went white. I tried to go into phpmyadmin and set the language to unpublished in xxxxx_languages table, this fixed the site. But administrator is still just white.

So where in the database is the setting for what language is being showed in administrator site so I can change it to something else?

  • If you have translated everything into Farose and would be interested in helping maintain the language pack, please contact the Joomla Translation team and help contribute to the Joomla project. Everything is made by volunteers. forum.joomla.org/memberlist.php?mode=group&g=47 – Søren Beck Jensen Sep 22 '15 at 7:25
  • Haven't made any translation, just took the danish translations and change the file names to fo-FO, so I can use it. but I'm having a really hard time to get this to work.. – Jeggy Sep 22 '15 at 8:58
2

Based on the error you provided in the screenshot, you need to go to the following file:

public_html/hammer/administrator/language/fo-FO/fo-FO.lcalise.php

at the top of the file, you will see the following snippet of code:

class da_DKLocalise {

which you need to replace with:

class fo_FOLocalise {
2

So you are not able to access the backend correct? You just see a white page when you try to do so? if that is the case you should enable error reporting in order to see what is causing the issue. https://www.ostraining.com/blog/joomla/white-screen-of-death/ try this guide on how to do it

  • Correct, but I know that if I just edit something in the database to select english instead of faroese to my administrator page it will work again, so I thought it would be easiest to just edit it directly in phpmyadmin somehow. Anyways: khp.randompoop.net/uploads/… – Jeggy Sep 21 '15 at 15:11
  • 1
    As far as i can understand you need to go to fo-FO.localise.php and on line 16 change the da_DKLocalise to fo-FO.localise.php as you said earlier you changed everything that had da-DK to fo-FO yet as you can see the php file calls for da_DKLocalise although it should be calling for fo-FO.localise.php. – Theodore Gavriilidis Sep 21 '15 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.