Whenever I save an Article using TinyMCE or JCE, I have Paragraph tags inserted below any HR's I have in the Article.

Initially, I was getting 4(!) Paragraph (open and close) tags after I saved, but after fiddling with the XML and PHP for TinyMCE - changing NewLines settings to False - this went down to one. But it was still one too many.

I then tried it in JCE editor and again, same issue. But still at just one inserted Paragraph.

Changing New lines from P to BR in TinyMCE settings made no difference whatsoever.

I'm wondering whether Joomla core is adding in the P tags, as both editors I try should be set to prevent it.

Has anyone had any experience with this one?

Help appreciated!


1 Answer 1


You need to do the settings in either TinyMCE or JCE based upon which one you are using (set in Global Configuration or overrided in your user account).

In JCE, the setting is in Editor Profiles->Default->Typography-> Container Element & Enter Key: JCE Typography - Container Element & Enter Key

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.