1

I'm on Joomla 3.4.3, PHP 5.4.40 and using reCaptcha for the contact form.

Whenever I use reCaptcha 1.0 everything works as intended. If I use reCaptcha 2.0 it's like this:

I fill the contact form, press "I'm not a robot", then I pass the test (it is verifying fine because if you make mistake it tells you to do it again) then I press Send Email... And it's like it reloads the page with the form still filled in... and the checkmark is gone on reCaptcha and I can keep doing the captcha indefinitely but it will refuse to work.

What is the problem? Any ideas?

console says stuff like:

Use of getAttributeNode() is deprecated. Use getAttribute() instead.

Which is an error/warning it shows on page load. But it's on reCaptchas side so I doubt I could do anything about it and it's shown on both 1.0 and 2.0 so I don't know if this is the problem here.

Just for you to know, I am not on old reCaptcha keys, I went to "getrecaptcha" just yesterday, and I've already tried to:

  • get new reCaptcha key
  • clear joomla cache
  • purge joomla expired cache
  • set all reCaptcha like settings in joomla control panel and pluging itself to be all turned off... then turned on again
  • switching back to protostar template to see if it might be a template issue

nothing really helped. And yeah, I'm using the built in joomla reCaptcha plugin.

UPDATE:

I tested this on my localhost copy... and seems to work fine there O_o what is going on here?

UPDATE2: Now that I see that the problem is only with my live page... Found this on my hosting's cpanel... could this be causing problem?

I also notice there's something called anti-hotlink enabled on the hosting... would that interfere with reCaptcha? enter image description here

UPDATE3:

I have tried other captcha plugins.

First went with [no Captcha Recaptcha by TechJoomla]http://extensions.joomla.org/extensions/extension/access-a-security/no-captcha-recaptcha

but it had exactly the same problem...

Then I tried [no Captcha Recaptcha by Bharat Kumar Dhaker] http://extensions.joomla.org/extensions/extension/access-a-security/no-captcha-recaptcha-joomla-plugin

The captcha by Bharat Kumar Dhaker works for me! I have checked and compared their code... first thing that comes to mind is that this one has something with curl in the code while others have no mention of curl. It's just a wild guess that it might be the reason why this one works but others, including the built in don't. I will not thoroughly compare the code of both plugins to see what makes it click :<

  • Do you by any chance have an extension that uses the Facebook API? Also, go to the System Settings on the Joomla backend and see if allow_url_fopen is set to On – Lodder Sep 4 '15 at 16:32
  • hi, where exactly is that setting? Can't find it. – Borg777 Sep 4 '15 at 16:40
  • couldn't find the setting in joomla backend so I went to edit htaccess and placed the line to enable url fopen. it didn't solve the issue. – Borg777 Sep 4 '15 at 17:02
  • System Settings >> PHP settings – Lodder Sep 4 '15 at 17:15
  • Nope, I don't have any system settings with php settings, I only have php settings shown in joomla's system info which is pretty much the same as going to the '<?php phpinfo(); ?>'. I did update my question because now I see the problem only happens on my live page but on localhost it works ok. – Borg777 Sep 4 '15 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.