1

I have been doing some speed optimization tests and changes to improve a joomla 3 site and now the site and admin works fine until I try and add a new article and the page will not load I just get a browser "Content Encoding Error". It seems to effect FireFox more than Chrome for some reason.

3

This could happen when gzip compression is enabled and your browser isn't configured to accept compressed content.

Try the following

  1. In Firefox address bar, type about:config
  2. If a warning is shown, accept and proceed.
  3. In search bar, type encoding
  4. For network.http.accept-encoding option, double click on value
  5. Change it to gzip,deflate. Click Ok.
  6. Refresh and try adding a new article.
  • It worked again turning off gzip, thank you. But why cant I have gzip on the frontend and off in the back? – tristanbailey Apr 25 '14 at 14:29
  • 1
    I am not too sure about if gzip is enabled for both (admin and frontend) or only frontend when you enable it from settings. Personally I too would prefer if it gets enabled only for frontend. But I believe that using htaccess you should be able to disable gzip for back end, e.g. administrator directory. – yetanotherse Apr 26 '14 at 19:14
1
  1. Clear the browser cache
  2. Clean Joomla Cache
  3. If it still does not work then disable 'Gzip Page Compression' global configuration.
  • 1
    This is not a browser cache issue, but can see those 3 steps as worth a try to teach people before checking other things – tristanbailey Apr 29 '14 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.