3

I've only noticed this issue on one of my sites. I recently upgraded it from 2.5 to 3.4

On certain (k2 contact) pages where there is an email address displayed I am seeing this right beside the email;

This email address is being protected from spambots. You need JavaScript enabled to view it.

When I view the source I also see strange JavaScript at this point in the page;

<script type='text/javascript'>
 //<!--
 document.getElementById('cloak99677').innerHTML = '';
 var prefix = '&#109;a' + 'i&#108;' + '&#116;o';
 var path = 'hr' + 'ef' + '=';
 var addy99677 = '&#101;d&#101;vl&#105;n492' + '&#64;';
 addy99677 = addy99677 + 'c2kn&#105;' + '&#46;' + 'n&#101;t';
 document.getElementById('cloak99677').innerHTML += '<a ' + path + '\'' + prefix + ':' + addy99677 + '\'>' +addy99677+'<\/a>';
 //-->
 </script>

Any ideas why this has happened, and how to solve it?

  • Have you got the Joomla email clock plugin enabled? – Lodder Aug 26 '15 at 13:35
  • I haven't checked - no doubt this will be the cause! – jonboy Aug 26 '15 at 16:09
3

That's the result of email-cloacking plugin. This is how an email address that exists inside the content, and is obfuscated with javascript, looks in the source code of the document, in order to be hidden from bots,

When Javascript is enabled, the above will result in the original email address be printed on the page - otherwise it will display the message you see.

From the message you are getting, we may conclude that either Javascript is disabled on the client side - or it can be some other kind of javascript issue.

Another example of cases where you could get this, instead of the email address, is if you are rendering this page's content, through a view that is not loading javascript e.g. a pdf generation layout, while the cloaking plugin has already replaced the email address with its obscured element.

Thinking the big image, protecting any email address from being exposed and grabbed by spambots is a good thing. But if this is giving your problems, then you can disable the Email Cloaking Plugin, from the plugin manager.

The core plugin is prone to giving errors of this kind. If you are looking for a more stable solution, then you could try NoNumbers Email Protector plugin - which is free.

  • Thanks for the detailed explanation of the issues. In the end I went with NoNumbers Email Protector - never knew this existed! – jonboy Aug 27 '15 at 8:03
2

This error occurs when you send a form and have some problem, the plugin "Content - Email Cloaking" hide the email address.

You can solve this, by disabling this plugin:

  1. Extension >> Plugin Manager >>
  2. Search "email" >>
  3. Disable "Content - Email Cloaking";
  4. Try again, this error won't happen again;
  • Thanks! I will check this. Although I'm not sending any forms, simply displaying (linked) email addresses on screen. – jonboy Aug 26 '15 at 16:10
  • @johnny_s :: The email cloaking is not related with form submissions. Is a content plugin that checks for email addresses inside the content and if it finds any, it uses regex to replace them with a small javascript code. – FFrewin Aug 26 '15 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.