1

as title goes, I'm trying to disable the Author page functionality from K2. Simply put I don't want any available author links in articles nor the possibility to access author pages. On this last point I want to be more specific: even if I disable all possible showing options of authors from the K2 configs, be it menu, category etc.. the author url is still reachable, with urls like domain.com/category/authors/123-authorname.

How can I disable all this? How can I have something like standard Joomla article author where there is only a text printed and no profile page linked to it?

I'm no PHP expert but digging in the code of the K2 component, it looks like it's directly embedded in the CCK functionalities with no direct option to disable it, am I wrong?

Note
In the main config options of K2 I've alreaddy disabled the "Enable K2 User Plugin" option, and set to hide to any possible option in the "Layout & view options for user (author) pages", still the authors pages are available and possible to reach even with no links pointing to them in the whole website.

I'm using the last version of K2 and Joomla! 3.4.1.

Update

My answer resolve the problem in a reasonable way. Tho as stated in my answer, instead of the Joomla! or custom template error.php page is served a basic Apache 404 page.
How can this be done via .htaccess redirecting to the template error page? Better to do a PHP redirect?

If anyone can find a similar option to redirect with a 404 to the custom template 404 page I will update as correct answer.

1

As I thought, the whole profile page is a core K2 functionality, no way to directly disable it.

So the only solution is to remove any link to these pages with overrides to either modules or K2 content.

Still the pages are active and reachable. In this case the best thing to do is to create a redirect rule, I did mine in .htaccess, but please che my update in my question. With this redirect I can block any author page requested and serve a system 404 error page.

RedirectMatch 404 ^.*/authors/.*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.