0

I transferred my site to a new server and now I'm getting this error when I click fix permission from Admins Tools (component). I also allocated Memory_limit to 300 but still same issue. Can somebody help in this regard?

Fatal error: Allowed memory size of 314572800 bytes exhausted (tried to allocate 32 bytes) in /home/*****/public_html/libraries/joomla/filesystem/folder.php on line 632

I am using Joomla! 3.4.1 Stable version.

enter image description here

  • You might have very big files or too many number of files inside a folder, or there is another issue with some of the files, that is causing the folder.php script to require too much memory. Review your files/folders in your root directory. – FFrewin Aug 15 '15 at 19:44
  • Dear FFrewin: I added screenshot of filesystem folder. Can you suggest what to do? – Naeem Aug 16 '15 at 15:01
  • Consider to update Joomla to the latest version, as for the files/folders I meant anywhere in your site - not particularly in the libraries folder. Check for any custom folders/files. – FFrewin Aug 16 '15 at 15:11
  • ...but yet I m not sure what I suggested above could be the issue. – FFrewin Aug 16 '15 at 15:34
  • Does it work ok on localhost? – jonboy Aug 17 '15 at 19:28
2

This is nothing to do with Joomla or the Admin Tools extension.

The following error that you're getting:

Fatal error: Allowed memory size of 314572800 bytes exhausted (tried to allocate 32 bytes) in /home/*****/public_html/libraries/joomla/filesystem/folder.php on line 632

Is simply telling you where the code is that's trying to fix the permissions.

The error means that your server does not have enough allocated memory to perform the task. Either your host has set low memory limits or you have a huge amount of recursive directories.

I would suggest opening your php.ini file and removing the limit like so:

memory_limit = -1

Please remember to change it back to the default value once finished

  • I have access on whm and increased memory limit to 300 and saved configuration but issues remained same. "a huge amount of recursive directories" can be considered. Secondly I did not understand memory_limit = value -1. Should i changed 300 memory limit to -1 in whm? – Naeem Aug 18 '15 at 17:37
  • Yes, try changing it to -1, then doing whatever you need to do on Admin Tools, then revert it back to its original value – Lodder Aug 18 '15 at 17:41
1

Have you try set php.ini memory? If you change the server probably your new host have a different configuration. If your joomla was running in the last server, it's a good idea to consider this option.

2015-09-08 You solve this? You can try add ini_set('memory_limit','64M') just below the

<?php
ini_set('memory_limit','64M');
class JConfig {
    public $offline = '0';
    public $offline_message = 'Offline message';
  • Yes I have all access on VPS, and my server provider is the same. I tried to allocate 300MB memory limit but still same issue. Do I also need to increase Execution Time limit? – Naeem Aug 17 '15 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.