1

I have problems with the url, are duplicating to google

http://www.villadelia.es/blog-de-bodas/sofia-y-ruben-una-boda-con-mucha-poesia

delete "blog-de-bodas"

http://www.villadelia.es/sofia-y-ruben-una-boda-con-mucha-poesia

and works.

I revised final of the archive .htaccess and is the same than another pages

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

if you dont mind help me.

6
  • 1
    DO YOU HAVE ANY SEF COMPONENT INSTALLED? – fruppel Aug 14 '15 at 17:56
  • @fruppel Please don't shout on Stack Exchange (i.e. no all-caps). Thank you! – Maximillian Laumeister Aug 14 '15 at 18:14
  • sry, I was just imitating the questioner ;-) – fruppel Aug 14 '15 at 18:18
  • Title fixed to the general style – Anibal Aug 14 '15 at 18:52
  • Fruppel thank you. No I not have any component sef only joomla – virtualsets Aug 14 '15 at 19:06
1

In Joomla, Sef Url cannot customized in .htaccess.

Url Routing is managed at Joomla level. You can work with the standard router or install an extension.

In both cases, router defines a path to access content according to your navigational menu organization.

You can have several valid access paths. Google discovers content navigating all published links. Thus, you have to restrict what it discovers.

If you want to only publish certain types of Urls, then you have to restrict public access paths.

PD: Even though, many valid access paths may exist to an object. In your example, you show an Url to an article in a category and the same article without category.

4
  • Hello and thank you Anibal. Why this not past whith another website www.video-boda.es in the same server with the same .htaccess. This are generating problems with google that find more articles. – virtualsets Aug 14 '15 at 19:10
  • Anibal where you think that I can find the problem, please put me a image. – virtualsets Aug 14 '15 at 19:17
  • You can have several valid access paths. Google discovers content navigating all published links. Thus, you have to restrict what it discovers. I guess you have several menu items for the same articles. – Anibal Aug 14 '15 at 19:24
  • Anibal this past with all the 43 articles. I only have 5 menuitems. I check disable all the modules and all the menuitems minus "home" and "blog", and also happens. Sorry my bad english – virtualsets Aug 14 '15 at 19:30
1

For the people that have my problem I find a solution, is very crazy and sorry my bad english

enter image description here

Only I change the article that link the menu item from number 1 to number 2

in this moments works well, it is not a problem of .htaccess and I see the article that the two is in the same category and not understand nothing, but works.

http://www.villadelia.es/blog-de-bodas/sofia-y-ruben-una-boda-con-mucha-poesia

than withought "blog-de-bodas"

Thank you and hope help any people the next time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.