0
  • Joomla 3.4.1
  • T3 Framework (v2.4.9)
  • Uber Template (v2.1.1)
  • xampp / win7

I'm having a really strange issue with front-end module editing (this is my secod post, deleted the first one as it was becoming very messy).

I am logged in as super admin and unable to see the icon when hovering over any module. Tried Uber template and default Protostar template.

After inspecting the html via the console (and tips from @Lodder) I have come to the conclusion that it must be a css issue, hopefully somebody can confirm/help.

In dev tools that when I hover over the module, some code appears in the console (shown below)

enter image description here

I presume this is the edit-module icon code, however I cannot see it.

I have added the following to my custom.css file which does allow me to see something (a black square);

.btn.jmodedit {
    width: 15px !important;
    height: 15px !important;
    background: #000000 !important;
}

This does show the icon (as a black square) when hovering over the module - see below.

enter image description here

I have no custom js files, no custom overrides, and only one custom.css (which I have deleted to ule out issue).

I have a few 3d party plugins such as RS Forms, Akeeba Backup and SJ Twitter. However I have disabled each of these individually and the problem still persists.

Firstly, what's going on? Secondly, how do I get the edit module icon to appear normal again?

Any help appreciated.

1

Lets try sticking with the default Protostar template for the time being. The template.css file for this also includes the Bootstrap CSS.

Now if you have a look at the image below, I've put a red box around the important areas.

In your inspector, if you click on the a tag, you should see the applied styling in the right hand side.


The first section is dynamic styling (not really important in your case).


The second section of styling comes from the following file:

media/system/css/frontediting.css


The last section comes from the template.css file which is all the Bootstrap styling for the button.


If you don't see the styling from section 2 and 3 in the right hand side red box, ensure both files exist.

enter image description here

If you want to continue the chat: http://chat.stackexchange.com/rooms/26061/discussion-between-johnny-s-and-lodder

1

Found the solution. T3 framework has an option to use 'Legacy Mode'. This is under Template > General > Legacy Compatible

With this set as 'No' I couldn't see the edi icon. Wit this set as 'Yes' I can.

According to the official T3 docs;

Legacy Compatible

When switched on this allows the template to parse older Bootstrap 2 and Font Awesome 3 styles.

No idea why this is an issue as I have other T3 sites with a similar setup - who knows!

Finally fixed! Hope this helps somebody. Thanks to @Lodder for all his help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.