1

I've recently been working on a website were I've upgrade it from 1.6 to 3 without any issues until I installed the Gantry framework and Template, I'm getting an unhelpful error message saying only error when trying to save. With the developers help I've narrowed it down to the error below but we're both unable to move forward from this.

Declaration of JFormFieldText::setup() should be compatible with JFormField::setup(&$element, $value, $group = NULL) in libraries/joomla/form/fields/text.php on line 265

I've reuploaded the text.php from a fresh joomla 3 install but without any help and any attempts to search for the error hasn't helped further.

https://gitter.im/gantry/gantry4 has the current exchange between myself and gantry where we tired to narrow down the issue.

1

I believe this is a strict error which should not normally affect the way the code works.

Try setting error reporting in the Joomla Global Configuration to "System Default". If it's already set to this, try turning it off to see if the error goes away.

I'm not sure how smooth the upgrade went, but try downloading a fresh copy of Joomla, and replace the following directories with the ones from the fresh copy:

  • administrator
  • components
  • libraries
1

Working further on the issue. There were left over files in the libraries/cms, joomla, legacy which onced deleted and the latest joomla files added in places resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.