0

I am receiving following error on loading www.jtsinstitute.com. kindly help me with the issue.

    [23-Jun-2015 07:21:55 America/Chicago] PHP Strict Standards:  Only variables should be assigned by reference in /home/jtsinst/public_html/plugins/system/socialloginandsocialshare/socialloginandsocialshare.php on line 87
[23-Jun-2015 07:21:55 America/Chicago] PHP Strict Standards:  Only variables should be assigned by reference in /home/jtsinst/public_html/plugins/system/socialloginandsocialshare/socialloginandsocialshare.php on line 91
[23-Jun-2015 07:21:55 America/Chicago] PHP Strict Standards:  Only variables should be assigned by reference in /home/jtsinst/public_html/plugins/system/socialloginandsocialshare/socialloginandsocialshare.php on line 93
[23-Jun-2015 07:21:55 America/Chicago] PHP Strict Standards:  Declaration of JParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in /home/jtsinst/public_html/libraries/joomla/html/parameter.php on line 512
[23-Jun-2015 07:21:55 America/Chicago] PHP Fatal error:  Call to a member function registerEvent() on a non-object in /home/jtsinst/public_html/plugins/content/module/module.php on line 15
  • What did you change right before these errors appeared? Does it work on localhost? – jonboy Jun 24 '15 at 8:18
1

OK, first, forget the strict messages for a while, they're not causing the issue. There's a fatal at "plugins/content/module/module.php"

That's an interesting extension....I don't have it in my tree and it's been too long since I've used 2.5 so I'm not sure what it does, but if it's new in your system, there's always the chance it's not compatible with the version of PHP or Joomla you're using. Here's some suggestions, based on your knowledge level:

1) If you're comfortable in PHP code, open that file and look at what it's doing on line 15. It might be doing something you can clearly see is wrong, and you can patch around it and continue.

Or:

2) Disable that module. You might be able to get away with simply renaming it or moving the entire module directory out of the plugins directory. If not you might need to go into the database table to disable it directly, if you can't get any other access to the back end.

As PHP has moved on, it enabled strict checking by default. The purpose of this was to show you what you were doing wrong, and give you some advance notice that what you're doing may break in the future. This has caught a lot of sloppy programmers off-guard, and it generates a lot of warning messages from them. You can control that from inside the general configuration settings, if you need to turn them off. (Personally, I think ignoring strict warnings is a Bad Idea. I'd look around for replacement extensions that don't throw warnings; maybe you'll be fine, but maybe the warning is an early indicator of something else that will fail soon as new versions of PHP ship, and finding replacements now will keep you from having to desperately search for them later, when it actually breaks.)

The world is changing constantly, and PHP and other server software will change along with it. Not keeping up is a good way to ensure something will break.

1

Strict errors are not a major issue. I'd simply suggest your turn them off in your php.ini file. In this file, you should see something like this:

error_reporting = E_ALL

which you should replace with this:

error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

Due to the blank page, I'd recommend setting error reporting in your Joomla Global Configuration to development.

  • php.ini file is not there in folder structure. – Siva Kumar Jun 23 '15 at 13:10
  • Try creating your own and putting it in the root of your Joomla cirectory – Lodder Jun 23 '15 at 13:11
  • i have upload php.ini file but it is not showing. same blank page. even admin side also some pages are same problem. – Siva Kumar Jun 23 '15 at 13:19
  • Ok, you can disable strict errors in your root index.php file, however this would be considered a core hack and will be overridden in the next Joomla update. Try contacting your hosting provider and ask them to do it – Lodder Jun 23 '15 at 13:22
1

The fatal error comes from "load module into article" content plugin by Carsten Engel. It was written in July 2011 for Joomla 1.5. It will not work. Uninstall it. Or update it to a current version from the authors webpage. That would probably keep any articles where you use it working correctly.

You can get rid of the strict standards errors by updating the social login plugin into version compatible with PHP 5.4 or by disabling error reporting.

0

Try this

Can you disable the plugins/system/socialloginandsocialshare plugin and check it your site.

  • I have renamed folder name but still it's not working. – Siva Kumar Jun 23 '15 at 12:44
  • Try disable the plugin and check it – Jextn Jun 23 '15 at 12:46
  • Better to try another solution goto bacend -> Global configuration -> Server -> Error reporting -> select none. – Jextn Jun 23 '15 at 12:51
  • i have try to disable the plugin but there also same problem. – Siva Kumar Jun 23 '15 at 12:54
  • Global configuration page also not loading in admin side. – Siva Kumar Jun 23 '15 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.