0

I am trying to upgrade my Joomla from 3.3.6 to 3.4.1. Whenever I press the update now button I get the following error:

0  Cannot open file for writing log

I tried the following:

  1. I created a php file to output the absolute path and added /tmp and /logs to my path to temp and path to log variables.
  2. I changed the permission for the logs and tmp folders and the configuration.php file and they are now readable and writable.

However , I am still getting this error message every time I try to update. Is there anything I need to edit further ?

8
  • Could you try following the first steps in my answer here? joomla.stackexchange.com/a/4674/168
    – Lodder
    Jun 17, 2015 at 14:16
  • 1
    So in the "System" tab in the Global Configuration, all directories and files listed are writable?
    – Lodder
    Jun 17, 2015 at 14:21
  • I did try all of them , I even tried updating through the Extension Manager then Install from URL , however this throws the following error: ` -1 Copy file failed`
    – girlintech
    Jun 17, 2015 at 14:22
  • Yes under System information -> Directory permissions all are writable.
    – girlintech
    Jun 17, 2015 at 14:25
  • 1
    If everything else fails you can also upgrade by unzipping the contents of the upgrade package inside your Joomla directory, overwriting existing files. That might or might not solve your problem, but at least you'd be up to date.
    – johanpw
    Jun 17, 2015 at 14:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.