3

I have given my Articles Titles but I mask them, and instead have a more friendly title as part of the page body.

I have a fully working and properly structured "menu bar" that looks as it should at the top of the page.

On every Article page, in the same font as a normal page title, above the title and separated by a "horizontal rule" is the Menu item title. If I try to set the "Show Title" setting for the Menu Item to "hide" then the menu item doesn't appear in the Menu.

The markup shows that the text appears in the following markup:

<h1 class="componentheading">Products</h1>

I need the Menu title to not appear in this way on any page of my site.

I am using Joomla 3.4 with the "JoomlArt Purity II" template.

Any help would be appreciated.

  • Apparently, the "Menu" is displayed based on a setting in the "Menus Manager" component: if you go to a specific Menu item and change "Show Page Heading" to "Hide", you will not see the Menu title above the page content... but if the "Show Page Heading" setting is "No" in the "Menus Manager" component, it does NOT have the effect of suppressing the "Page Heading" from being rendered (which defaults to the "Menu Title" text)... but after setting the "Show Page Heading" on a single page then setting it back to "Use Global" it seems to be working sitewide now. Shrug. – Ryan Germann Jun 15 '15 at 20:08
1

It looks complicated, but in fact it's not:

  1. If you want to have a header/title on each Article page tagged with <h1> in HTML code (it is important for SEO purposes also) you should use 'Show Page Heading' setting. Global setting for that you can find in 'System/Global Configuration/Menus Manager/Page Display'. From here you can set it for all pages/the whole site. If you want to personalize some pages you can change that setting in the respective menu item using 'Menu Manager'.

  2. If you want Article titles tagged with <h2> in HTML you should open 'System/Global Configuration/Articles (Article Manager Options)' and check 'Show Title'. Individual menu items could be personalized in the same way - through Menu Manager.

Both titles are independent of each other.

  • Thanks for taking the time to reply. With Joomla, what I find most difficult is locating interrelated settings, scattered as they are. In this case I had the Global "Show Page Heading" set to "Hide" or "No", but it was still being rendered... after going into an INDIVIDUAL Menu item and setting an exception for "Show Page Heading" to "No", it was hidden on that single page... so then I put it back to "use Global" and toggled the Global setting, and it worked properly on all pages. Whether a bug in Settings, or a browser cache issue, Google returned no useful results. Thanks to you, it will. – Ryan Germann Jun 17 '15 at 13:42
  • Most probably cache issue. Did you clear Joomla cache also? 'System/Clear Cache' – pl71 Jun 17 '15 at 14:04
  • I tried a lot of thing (you know, flailing when nothing you do has any visible effect) but keeping in mind that clearing both the Browser and System cache when doing this kind of work (hiding specific content types / titles etc. in a Joomla Template's settings) is good advice. Thanks. – Ryan Germann Jun 19 '15 at 13:02
0

Hope this helps someone. I had same issue. Joomla just sucks - they do a very poor job of being easy to use and intuitive. Anyway, I am using the Protostar template and all the options mentioned above did not work for me (menu, global setting, etc...)

I had to edit the html associated with the Protostar template.

Extensions -> Templates Click "Templates" on the left hand side Click "Protostar Details and Files" Click "index.php"

Comment out the line beginning with "$sitename = " and save. I noticed this returned after a recent Joomla upgrade.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.