0

Hello I am having some issues for integrate a custom component of joomla in Falang for multilanguage website

Debugging I got null:

Fatal error: Call to a member function getTable() on null

object(ContentObject)[183] public '_contentElement' => null

My XML for integrate my component looks as:

 <?xml version="1.0"?>
    <falang type="contentelement">
      <name>Members</name>
      <author>Stackoverflow.com</author>
      <version>1.0.0</version>
      <description>Definition for the core Members component</description>
      <copyright>stackoverflow.com</copyright>
      <reference>
        <table name="chambercommerce_members">
            <field type="referenceid" name="id" translate="0">ID</field>
            <field type="titletext" name="company_name" translate="1">Company Name</field>
            <field type="text" name="country" translate="1">Country</field>
            <field type="text" name="benefits_discounts" translate="1">Benefits</field>
            <field type="text" name="web" translate="0">Web</field>
        </table>
      </reference>
      <translationfilters>
         <frontpage>id</frontpage>
         <keyword>company_name</keyword>
         <id>id</id>
      </translationfilters>
    </falang>

I make my xml looking the others one in my joomla installation for falang and there is this var_dump.

<em>object(ContentObject)[180]  public '_contentElement' => object(ContentElement)[179]  public '_xmlFile' => ...</em>

Any help for fix it?

1

I did it.

The issue: xml name should be iqual to database table name. SO I rename to mytable.xml and it worked perfectly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.