I need to disable JCE component on the backend because it is stripping code in certain articles/components.

In global configuration, I tried changing the editor to codemirror or none, but it doesn't matter: whenever I create new content, I get JCE as the editor.

I also disabled JCE component from the extensions/manage menu, but JCE is really persistent!

I also cleared cache (including browser's), but nothing!

Help anyone?

1 Answer 1


Which editor will be used can be controlled by each user. So it's possible that inside your user settings you have selected the JCE editor as your editor's choice.

Generally, you can go into the Plugin manager -> Editors and disable the JCE editor plugin, which will make it unavailable across the Joomla site.

However, JCE provides plenty of customizable options. Most likely you can tweak it, so it won't strip out the code you are trying to insert. You can even create various profiles with different behavior or set of features and assign them to specific users/usergroups or extensions.

Finally, keep in mind that it's not only the JCE that might strip out your code. Joomla itself has filtering options. You can review them at Global Configuration -> Text Filter tab.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.