I am trying to update my 3rd party component. But the installer after a while returns the error message, that the component failed to install and the warning "Copy File Failed". System information reports that Joomla directory permissions are ok (all writable).

I tried installing also from the tmp directory - but yet the same error.

Joomla version is 3.4.1

4 Answers 4


Just my 2 cents as there could always be some other issues.

In regards to permissions, it's not always the chmod levels that need changing. It may sometimes be due to the directory group permissions. Changing the the group permissions can be achieved easily through SSH with a tool such as Putty and the following command:

cd path/to/parent/directory
chgrp -R directory GROUP_NAME

-R means "recursive" and this is optional

Another possible cause might be that the tmp directory has not been set correctly in the Joomla Global Configuration. This is a common mistake when users migrate a site from one server to another manually (without the likes of Akeeba Backup).

  • this is useful information for anyone that might face this kind of issues
    – FFrewin
    Commented May 26, 2015 at 12:47
  • To add to this: I have even came across with directory/files owner permission issues. So someone should be also aware of this. Someday, If in the proper mood, I might add an answer regarding how to change owners.
    – FFrewin
    Commented May 30, 2015 at 13:09

It proved to be a permissions issue. As always Akeeba Admin Tools come in handy in such issues. I installed it, configured the permissions settings and applied the fix permissions feature.

Tried to install again the update and this time it went smoothly and completed.

This answer solved my issue - but @Lodder's answer provides a few additional information when permissions issues occur, - so make sure you read it.


In my case, I think it was because I don't close vim so swap files .swp exists in my dev folders!

With J!3.9.12 and 4.0.0-alpha10-dev

  • Thank you for contributing. Please take the tour. Commented Oct 24, 2019 at 10:04

In my case i solve with two lines:

First, I changed the ownership of all files and folders for the user of my hosting.

chown -R groupname:ownername public_html

Then I changed the group's permission to "nobody". In my case, my server has HWM and the public_html folder needs to have this permission to run the sites.

Change only public_html permission to:

chown nobody:ownername public_html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.