5

I am trying to change the author meta tag. Now, when a user goes to share something to facebook, then the author meta tag is displayed his name. I want to change it to his username.

thank you

5

Username is used for login - it's the half info required for someone to login into the website. Therefore, it is not a wise idea to reveal such sensitive data to the public.

There is always the author alias field that can be used on a per article basis, to override the author name. See screenshot below:

enter image description here

Alternatively, you could just change the name of the author-user to a nickname desired for signing the articles, but anyhow avoid publishing the login username.

As a last note, keep in mind that you can totally hide the meta-author tag, from the global configuration settings.

Update for the comment:

I need it for the use of facebook share, because it is generating the name of the author and i do not want this. and it is difficult for every article to change the author name to a nickname. So in global configuration i disable the meta-author tag but the name is still displayed in the preview facebook share.

Answer:

As for why FB still publishes the author, after changing the Global Configuration settings, it can be cached data. Apart of "local" Joomla cache, FB scrapper also caches the content of a page, and it won't show any changes in the meta in less than 24 hours.

You can review how FB sees your page at the FB scrapper debug tool:

https://developers.facebook.com/tools/debug/

Also this Q/A might be helpful regarding Facebook: Facebook Share - Remove: "The Joomla! content management system lets you create webpages..."

But first you want to make sure that you have actually removed the author metatag from your pages. Although disabled from the global configuration, a 3rd party SEF extension, or an extension to generate the FB og:meta, might still keep injecting the author-meta in the head of the html of your page.

Checking the head of the html page in the source code of your page with your browser's inspector will help you see, if the following metas have been removed:

<meta name="author" content="authorname">
<meta property="article:author" content="authorname">
  • Lodder thanks for the screenshot addition. – FFrewin May 19 '15 at 9:42
  • Was in the process of writing up my answer which was the same so thought I'd donate the screeny to you :) – Lodder May 19 '15 at 9:42
  • @FFrewin thanks for the information. i need it for the use of facebook share, because it is generating the name of the author and i do not want this. and it is difficult for every article to change the author name to a nickname. so i global configuration i disable the meta-author tag but the name is still displayed in the preview facebook share.. – giorgionasis May 19 '15 at 10:23
  • @giorgionasis:: It can be cached data. Also it can happen due to 3rd party SEF extension, or an extension to generate the FB og:meta, that is still injecting an author-meta. – FFrewin May 19 '15 at 10:41
  • @giorgionasis:: Check updated answer for more info – FFrewin May 19 '15 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.