Joomla Stack Exchange is a question and answer site for Joomla! administrators, users, developers and designers. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For whatever reason, I can't make the JCE Editor appearing for my custom usergroups in front-end.

I have tried so many combinations and still can't make it work.

At the moment I have ended up with only the Default JCE Profile, assigned to all the groups except the guest group and I also gave extended JCE permissions to these groups.

But still the editor (in front-end) will display only to groups that have backend access and not to those that have only front-end access.

I have checked it also with the ACL manager but I didn't noticed anything apparently wrong... Another thing to note is that there are no any JS conflicts that could cause any issues.

Is it possible that I am missing something obvious, ACL related, or a setting somewhere that manages editor access to the front-end?

share|improve this question
    
Are you sure you are logged in with a user that belongs to one of these groups? Silly question but I only ask because it has happened to me before – Lodder Jun 13 '14 at 11:24
    
well good point, let me check once again... but during my troubleshooting, I am sure I have assigned the jce to all usergroups, that includes those I was testing with. – FFrewin Jun 13 '14 at 11:29
up vote 3 down vote accepted

Guys after messing around with the ACL in all other places, and checking for any kind of possible other issues for some hours, finally I managed to sort this out.

The issue was caused by the ACL settings on the JCE Editor plugin, which is being called when it comes to load the editor. It had access level to Administrator, so any front-end users were unable to get access and load the editor.

I set its access to Public and now I have the editor loading on Front-end for all my usergroups.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.